当前位置:首页>文章中心>技术文档>配置基于VLANIF接口地址池的DHCP服务器

配置基于VLANIF接口地址池的DHCP服务器

发布时间:2018-01-30 点击数:953

组网需求如图,

某企业有两个处于同一网络内的办公室,为了节省资源,两个办公室内的主机由 Switch1作为 DHCP 服务器统一分配 IP 地址。

楼层一所属的网段为 192.168.2.0/24,主机都加入 vlan 2,(可选:地址租期为 30 天);

楼层二所属的网段为 192.168.3.0/24,主机都加入 vlan 3,(可选:地址租期为 20 天);

DNS 为 183.221.253.100(运营商 DNS);

注:楼层交换机 SW2 和 SW3 都作为 HUB 交换机使用,无需任何配置,即插即用;


工具/原料

  • 华为三层交换机一台

方法/步骤

  1. SW1 配置如下:1、创建 vlan

    <SW1> system-view                          //进入系统模式

    [SW1] vlan batch 2 to 3                    //新建 vlan 2-3


  2. 使能 dhcp 服务[SW1] dhcp enable              //系统视图下使能 dhcp 服务


  3. 配置 vlanif 接口地址作为 dhcp 地址池给 PC 电脑分配 IP 地址

    [SW1] interface Vlanif 2                                     //系统视图进入 vlanif2 接口

    [SW1-Vlanif2] ip address 192.168.2.1 24             //配置 PC 电脑的网关地址[SW1-Vlanif2] dhcp select interface          //使能接口地址池 dhcp 服务功能[SW1-Vlanif2] dhcp server dns-list 183.221.253.100             //配置 DNS

    [SW1-Vlanif2] dhcp server lease day 30     //配置 dhcp 地址的租期为 30 天[SW1] interface Vlanif 3

    [SW1-Vlanif3] ip address 192.168.3.1 24

    [SW1-Vlanif3] dhcp select interface

    [SW1-Vlanif3] dhcp server dns-list 183.221.253.100

    [SW1-Vlanif3] dhcp server lease day 20



  4. SW1----SW2, SW1----SW3,接口加入相应 vlan

    [SW1] interface GigabitEthernet 0/0/1                 //对接 SW2 交换机

    [SW1-GigabitEthernet0/0/1] port link-type access

    [SW1-GigabitEthernet0/0/1] port default vlan 2

    [SW1] interface GigabitEthernet 0/0/2                //对接 SW3 交换机[SW1-GigabitEthernet0/0/2] port link-type access

    [SW1-GigabitEthernet0/0/2] port default vlan 3

    [SW1-GigabitEthernet0/0/2]quit

    <SW1>save


  5. 验证结果,PC1和PC2能够通过DHCP获取到地址,ping互通。



在线客服